Last Update: 2011-09-11 (日) 01:19:43 (2085d)
FrontPage / network / IPv6 / IPv6PPPoE対応ルータ

フレッツ光ネクスト(NGN) IPv6 PPPoEに対応したルータ一覧

メーカ型番対応Firmware/Ver備考
NECIX2005フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECIX2015フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECIX2105フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECIX2025フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECIX3010フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECIX3110フレッツ 光ネクスト向け IPv6インターネット接続 設定ガイド(IPv6 PPPoE)
NECAterm WR8371N
YAMAHARTX1200Rev.10.01.32 フレッツ 光ネクストでインターネット接続(IPv6 PPPoE)を使用するには、どうすればよいですか?
NTT東西MA-100
Cisco次のIOS以降をサポートするルータ12.2(13),12.3以降詳細:Cisco IOS Software Release Specifics for IPv6 Features
IIJSEIL/x86説明:NGN IPv6への接続の設定(ppp, interface, route6)
IIJSEIL/X1?
IIJSEIL/X2?
FURUKAWAFITELnet F80?
FURUKAWAFITELnet F140設定例:PPPoE接続(IPv6インターネット)
FURUKAWAFITELnet F100設定例:PPPoE接続(IPv6インターネット)
FURUKAWAFITELnet F200設定例:PPPoE接続(IPv6インターネット)
FURUKAWAFITELnet F2000設定例:PPPoE接続(IPv6インターネット)
AlliedTelesysARX640S機能としては実装しているが6/15現在正式対応外
AlliedTelesysAR570S機能としては実装しているが6/15現在正式対応外
日立製作所DS-RA01

そのほか環境での接続

Config

IX2010/2015/2025

Router# enable-config
Router(config)# ipv6 route default FastEthernet0/1.1
Router(config)# proxy-dns ipv6 enable
Router(config)# ppp profile next
Router(config-ppp-next)# authentication myname foo@example.com
Router(config-ppp-next)# authentication password foo@example.com password
Router(config-ppp-next)# exit
Router(config)# ipv6 dhcp client-profile dhcp6
Router(config-ipv6-dhc-dhcp6)# option-request dns-servers
Router(config-ipv6-dhc-dhcp6)# option-request ntp-servers
Router(config-ipv6-dhc-dhcp6)# ia-pd subscriber FastEthernet0/0.0
Router(config-ipv6-dhc-dhcp6)# exit
Router(config)# interface FastEthernet0/0.0
Router(config-FastEthernet0/0.0)# ipv6 enable
Router(config-FastEthernet0/0.0)# ipv6 nd ra enable
Router(config-FastEthernet0/0.0)# no shutdown
Router(config-FastEthernet0/0.0)# interface FastEthernet0/1.1
Router(config-FastEthernet0/1.1)# ppp binding next
Router(config-FastEthernet0/1.1)# ipv6 enable
Router(config-FastEthernet0/1.1)# ipv6 dhcp client dhcp6
Router(config-FastEthernet0/1.1)# no shutdown

FITELnetF80/F100/F140/F200

Router# configure terminal
Router(config)#
Router(config)# interface lan 1
Router(config-if lan 1)#
Router(config-if lan 1)# ipv6 nd send-ra
Router(config-if lan 1)# ipv6 enable
Router(config-if lan 1)# exit
Router(config)# interface pppoe 1
Router(config-if pppoe 1)#
Router(config-if pppoe 1)# pppoe server A-Provider
Router(config-if pppoe 1)# pppoe account user@xxxx.ne.jp secret
Router(config-if pppoe 1)# pppoe type host
Router(config-if pppoe 1)# exit
Router(config)# ipv6 route ::0/0 pppoe 1
Router(config)# proxydns mode v6
Router# save SIDE-A.cfg

Cisco

ip cef
ipv6 unicast-routing
ipv6 cef
!
!
interface FastEthernet0
ipv6 address IPv6 0:0:0:FFFE::/64 eui-64
ipv6 enable
!
interface FastEthernet1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
no ip address
encapsulation ppp
dialer pool 1
ipv6 address autoconfig
ipv6 enable
ipv6 dhcp client pd hint ::/0
ipv6 dhcp client pd IPv6
ppp authentication chap callin
ppp chap hostname IPv6@example.com
ppp chap password 0 cisco
!
!
ipv6 route ::/0 Dialer1

IIJ SEIL/x86

 1. ppp add ipv6 keepalive none ipcp disable ipcp-address off ipcp-dns off ipv6cp \
    enable authentication-method chap identifier <ppp account> passphrase \
    <ppp password> tcp-mss auto
 2. interface pppoe0 ppp-configuration ipv6
 3. interface pppoe0 over lan1
 4. route6 add default pppoe0
 5. dhcp6 client enable
 6. dhcp6 client interface pppoe0
 7. dhcp6 client prefix-delegation subnet lan0 sla-id 0x1 enable
 8. dhcp6 server interface lan0 enable
 9. dhcp6 server interface lan0 dns add dhcp6
10. rtadvd enable
11. rtadvd interface lan0 enable
12. rtadvd interface lan0 other-flag on
13. rtadvd interface lan0 advertise auto
14. rtadvd interface lan0 advertise add interface-prefix

YAMAHA RTX1200

ipv6 route default gateway pp 1
ipv6 prefix 1 dhcp-prefix@pp1::/64
ipv6 lan1 address dhcp-prefix@pp1::1/64
ipv6 lan1 rtadv send 1 o_flag=on
ipv6 lan1 dhcp service server
pp select 1
 pppoe use lan2
 pp auth accept pap chap
 pp auth myname (ISPに接続するID) (ISPに接続するパスワード)
 ppp ccp type none
 ppp ipv6cp use on
 ipv6 pp dhcp service client
 pp enable 1
dns server pp 1
         

参考情報

IPアドレス取得には次の実装が必要。

IPv6 prefix 取得時に使用するオプションコード

OP code内容説明
25Identity Association for Prefix DelegationIA_PD に関する情報
26Identity Association for Prefix Delegation prefixIPv6 prefix
TOPページへ戻るページの更新   ページの編集新しいページの作成新しい下位ページの作成そのページを引用して新規作成そのページにファイルの添付ページの削除ページ名の変更前回の編集内容の表示ページの凍結バックアップページの参照ページへのリンク元を表示   サイトのページ一覧サイト内単語検索編集したページの履歴削除したページの履歴   別ウィンドウでマニュアルページへ